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1 Introduction to the DPOJET USBSSP Setup Library 

 

This document provides the Methods of Implementation (MOI) for making USB Super Speed Plus (SSP) 

measurements with Tektronix DPO/DSA/MSO 70000 Series real time oscilloscopes (16 GHz models and 

above) and probing solutions. The USBSSP technology has 10Gb/s data rate. 

 

DPOJET (Jitter and Eye Analysis Tools) is available on DPO/DSA/MSO 70000 Series instruments.  

Setup files using DPOJET measurements are used to perform USB 3.1 specific measurements. DPOJET 

along with its associated setup files, provides transmitter path measurements (amplitude, timing, and 

jitter), waveform mask testing and limit testing described in the USB 3.1 specification at respective test 

points.  

1.1 Supported Specifications 

 Universal Serial Bus 3.1 Specification, Informative and Normative Transmitter. 

Refer to http://www.usb.org/developers/docs/ for the latest specifications. 

 

In the subsequent sections, step-by-step procedures are described to help you perform USB 3.1 

measurements. Each measurement is described as a Method of Implementation (MOI).  

 

For the latest version of this document and the latest USB 3.1 DPOJET Setup Library refer to 

www.tek.com/software, (keyword ‘DPOJET USBSSP’).  

 

For further reference on USB test specifications and compliance testing, consult documents offered to 

USB- IF members at www.usb.org. 
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2 Differential Transmitter (TX) Eye Diagrams 

 

Figure-1 shows the eye mask definitions for the USB 3.1. 

The eye diagrams are a graphical representation of the voltage and time limits of the signal. This eye 

mask applies to jitter after the application of the appropriate jitter transfer function and reference receiver 

equalization. In all cases, the eye is to be measured for 106 consecutive UI.  

 

Referring to the figure, the time is measured from the crossing points of Txp/Txn. The time is called the 

eye width, and the voltage is the eye height. The eye height is to be measured at the maximum opening 

(at the center of the eye width ± 0.05 UI).  

 

The eye diagrams are to be centered using the jitter transfer function (JTF). The recovered clock is 

obtained from the data and processed by the JTF. The center of the recovered clock is used to position the 

center of the data in the eye diagram.  

 

The eye diagrams are to be measured into 50-Ω single-ended loads. 

  

 

 

Figure 1: Generic Eye Mask 
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3 SuperSpeed Plus USB Setup Library  

The SuperSpeed Plus Setup Library consists of the following software file types.  

3.1 USB 3.1 Setup Files for the DPO/DSA/MSO 70000 

System Location: C:\Users\Public\Tektronix\TekApplications\USBSSP\Setups\  

Description: 

The USB folder contains three folders, Scope, SDLA and DPOJET.  

The Scope folder has two subfolders, Host and Device. The Device folder has USBSSP_Cable_embed.set  

setup file which applies arbitrary filer on Ch1-Ch3 using MATH. The filter represents the long cable 

function 

 

The SDLA has 8 setup files, corresponding from 0 to 6 dB presets. This will generate the equalized 

waveform. USBSSP_CTLE_Optimized.sdl setup file will optimize between 0dB to 6dB and will find out 

maximum eye opening for the acquired waveform(s).  

 

The DPOJET has 9 setup files for standard and micro connectors as shown below. Each setup file will 

instantiate group of measurements corresponding to normative and informative using compliance 

patterns. There are three setup files pertaining to various link training sequences LFPS, SCD and LBPS. 
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For Type-C connectors, another 4 setup files are available under ‘TypeC’ folder. 

 

3.2 Selecting a Test Point and Channel Model 

Two compliance points are defined in the specification - Normative Transmitter Test Point 

(TP1) and Informative Transmitter Test Point. 

3.2.1 Normative Transmitter Test Point (TP1) 

 

Table 6-17 of USB 3.1 specification represents the Normative Test Point, defined as TP1 in 

Figure 6-14 in the specification. Compliance measurements in Table 6-17 are made after 

acquiring the waveform at ‘TP1’ for the device under test as shown in the following diagram. 

 

Figure 2: Test points 

The compliance channel model is combined with the CTLE (Continuous Time Linear 

Equalization) and DFE (Decision Feedback Equalizer) functions with SDLA. It is then 

applied to the acquired waveform and analyzed for compliance using DPOJET. The 

result gives the measurement values along with the Pass/Fail report. 

 

3.2.2 Informative Transmitter Test Point 

 

Tables 6-15 and 6-18 of the specification define parameters to be taken at the pins of the 

transmitter device and represent the Informative Transmitter Test Point. This test point requires 

the measurement channel be De-Embedded from the measurement. The waveform is acquired 



Method of Implementation 

DPOJET USB3.1 MOI                                                                                                                                  

10 

 

at ‘TP1’ as with the Normative test. 

3.3 USB 3.1 Channel Model Filters  

 

Filter Library File Path: C:\Users\Public\Tektronix\TekApplications\USBSSP\Filters\ 

 Description: 

The USB 3.1 Math Arbitrary Filters library allows you to perform SW Channel Emulation of 

reference channels defined in the specification.  

3.4 USB 3.1 Waveform Masks  

Mask Library File Path: C:\Users\Public\Tektronix\TekApplications\USBSSP\Masks\  

Description:  

The USB 3.1 Mask library contains the waveform mask files used by the various setup files. 

Waveform masks are used to perform Pass/Fail template testing on the waveform eye diagram.  

3.5 USB 3.1 Limits Files 

Limit Library File Path: C:\Users\Public\Tektronix\TekApplications\USBSSP\Limits\  

Description: 

The USB 3.1 Limits library contains the measurement limit files used by the various setup 

files. Measurement limits are used to provide Pass/Fail indication for each measurement.  

 

Important: The Setup file defines the system location of the Channel Model Filter, Mask, and Limits 

files used for the test. Thus, all files must be in the proper location for correct operation. 
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4 Differential Transmitter Specifications (Informative & Normative) 

The following table shows the available measurements in DPOJET and their test limits defined at each 

point in the Specification. The Informative Tx test point is defined at the pins of the transmitter device 

USB 3.1 link. The Normative Rx test point is defined at the end of a reference channel. 

Table 2- Supported MOIs - USB 3.1 specification transmitter measurements 

Spec Reference Symbol(s) Parameter 
DPOJET measurement 

method 

Limits 

Table 6-17 UI 
Unit Interval (no 

SSC ) 
SSP UI 

100.53 ps (max) 

99.97 ps (min) 

Table 6-17 VTx-Diff-PP 
Differential p-p Tx 

voltage swing 
SSP VTx-Diff-PP 

1.2 V (max) 

70 mV (min) 

Table 6-17 
VTx-Diff-PP-

LOW 

Low-Power 

Differential p-p Tx 

voltage swing 

SSP VTx-Diff-PP 

 

800 mV (max) 

70 mV (min) 

Table 6-17 SSC dfdt df/dt SSC dfdt 
1250 ppm (max) 

 

Table 6-18 tMIN-PULSE-Dj 
Deterministic min 

pulse 
SSP Tmin-Pulse-Dj 

96 ps (max) 

Table 6-18 tMIN-PULSE-Tj Tx min pulse SSP Tmin-Pulse-Tj 
90 ps (max) 

Table 6-18 tTx-EYE Eye Width Width@BER 
48 ps (max) 

Table 6-19 TX-EYE Transmitter Eye 
Eye Height1 

(Tbit or Both) 

1.2 V (max) 

70 mV (min) 

Table 6-19 

Table 6-15 
TJ TJ at 10-12 BER TJ@BER 

67.1  ps(max) 

35.4 ps(max)(Informative) 

Table 6-19 

Table 6-15 
RJ-dd Tx RJ-dd RJ–δδ 

1.0 ps (max) 

1.31 ps(max)(Informative) 

Table 6-17 

Table 6-15 
DJ-dd Tx DJ-dd DJ–δδ 

53ps (max) 

17 ps(max)(Informative) 

Table 6-16 tSSC-MODRATE Modulation Rate 
USB-SSC-MOD-

RATE 

33 KHz (max) 

30 KHz (min) 

Table 6-17 

tSSC-FREQ- 

DEVIATION- 

MAX 

SSC deviation 
SSC-FREQ-DEV-

MAX 

300 ppm (max) 

-300 ppm (min) 

Table 6-17 

tSSC-FREQ-

DEVIATION-

MIN 

SSC Deviation SSC-FREQ-DEV-MIN 

5300 ppm (max) 

-3700 ppm (min) 
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Table 6-18 
DC Common 

Mode Voltage 

VTX-DC-CM DC Common Mode 
2.2 V (max) 

Table 6-18 
AC Common 

Mode Voltage 
VTX-CM-ACPP_ACTIVE AC Common Mode 

100 mV (max) 

Table 6-20 Preshoot Preshoot USBSSP Preshoot 
3.2 dB (max) 

1.2 dB (min) 

Table 6-20 De-emphasis De-emphasis USBSSP DeEmphasis 
-2.1 dB (max) 

-4.1 dB (min) 

Table 6-31 SCD tRepeat 
tRepeat0 

tRepeat1 
SCD tRepeat 

Logic ‘0‘ 

Logic ‘1’ 

Table 6-32 LBPS tPWM tPWM LBPS tPWM 
2.4 us (max) 

2 us (min) 

Table 6-32 LBPS tLFPS 

tLFPS 0 

LBPS tLFPS 

0.8 us (max) 

0.5 us (min) 

 

tLFPS 1 

1.8 us (max) 

1.33 us (min) 

Table 6-28 LFPS tPeriod tPeriod LFPS tPeriodSSP 
80 ns (max) 

20 ns (min) 

Table 6-29 LFPS tRepeat tRepeat LFPS tRepeat 
14 us (max) 

6 us (min) 

Table 6-29 LFPS tBurst tBurst LFPS tBurst 
1.4 us (max) 

600 ns (min) 

Table 6-28 LFPS tRiseTime tRise2080 LFPS tRiseTime 4 ns (max) 

Table 6-28  LFPS tFallTime tFall2080 LFPS tFallTime 4 ns (max) 

Table 6-28  LFPS DutyCycle Duty cycle LFPS DutyCycle 
60 (max) 

40 (min) 

Table 6-28  LFPS AC CM VCM-AC-LFPS LFPS AC CM 100 ns (max) 

Table 6-28  LFPS DIFF PP VTX-DIFF-PP-LFPS LFPS DIFF PP 
1.2 V (max) 

800 mV (min) 

5 Preparing to Take Measurements   

5.1 Required Equipment  

The following equipment is required to take the measurements: 

• Oscilloscope: 16 GHz model is suitable for debug purpose. 
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o (TekScope v 10.3.0 Win 7 Scopes or above only) 

o DPOJET Jitter and Eye Analysis Tool application (v 10.0.0 or above).  

• SDLA64 software for Channel De-Embed and custom filter development (v3.0.0.2 or 

above) 

• Probes – Two TCA-SMA  

6 Probing Options for Transmitter Testing 

6.1 Two TCA-SMA Connectors (Ch1-Ch3 Pseudo-Differential)  

The differential signal is created by the DPOJET from the math waveform Ch1-Ch3. This probing 

technique requires breaking the link and terminating into a 50 Ohm termination of the oscilloscope. 

Ch- Ch deskew is required using this technique because two channels are used. This configuration 

does not compensate for cable loss in the SMA cables. The measurement reference plane is at the 

input of the TCA-SMA connectors on the oscilloscope. Any cable loss should be measured and 

entered into the vertical attenuation menu for accurate measurements at the SMA cable attachment 

point.  

7 Accessing the DPOJET USB 3.1 Measurement Menu 

• On DPO70000 series, go to Analyze> USBSSP Essentials 
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Figure 3: Default menu of the DPOJET software 

8 Configuring the Software  

8.1 Selecting Measurements  

In the DPOJET USBSSP menu, select the desired measurements. One can select either a single 

measurement or recalling a setup file he/she can run multiple measurements at a time. Recalling 

setup files will give all the required setup for those measurements by default. 

 

Figure 4: Jitter and Eye Analysis window for single measurement selection 
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8.2 Selecting Limit Files  

If  a  measurement  has  a  pass/fail  limit  associated  with  it  in  the  test  point  file,  go  to 

Analyze>Jitter and Eye Analysis>Limits to select the limit file from the folder where the limit 

files are saved. Measurements with pass/fail limits will show up in the Results Summary panel 

when the compliance test is run.  

8.3 Configure Mask file:  

• In the DPOJET application go to ‘Plots’ if you want to enable the Mask file. 

• Select measurement from the measurement column.  

• Click ‘Configure’ to change the default setup for that measurement. The mask file 

selection window opens as shown:  

 

• In the Mask file selection window, press the ‘Off’ button first and then click 

‘Browse’ to select the Mask file. 

Select the relevant mask files (For example, USBSSP_Rx_NORMATIVE.msk) file and click 

‘Open’.  

• Enable the file by selecting the ‘On’ button, and click OK. 

8.4 Configure Clock Recovery  

In the Configure menu, select Clock Recovery and select the type of clock recovery to be used. 

If you are using DFE CK, setup DPOJET as follows: 
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Figure 5: Clock Recovery selection window 

You can also set up the DPOJET to recover the Clock, as follows: 

• Select Method >PLL-Custom Bandwidth. 

• Select PLL Model > Type II  

• Select Damping > 0.707  

• Select Bandwidth 7.5 MHz. 

• Select advanced button and configure Bit Rate to 10Gb/s. 

 

Figure 6: Clock Recovery selection window  
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8.5 Channel Models:  

The Channel Models are available in the “DSA/Channel Filters” folder in the distribution at  

C:\Users\Public\Tektronix\TekApplications\USBSSP\Filters  

9 USB3.1 Transmitter Test Procedure 

This section provides the Methods of Implementation (MOIs) for Transmitter tests using a 

Tektronix real-time oscilloscope, probes, and the DPOJET software. 

9.1 Step-by-Step Normative Testing 

The following procedure discusses how to use DPOJET to test the Normative test point in the 

USB 3.1 Specification. Differences in the procedure for testing the Informative test point are 

discussed but not detailed. 

9.2 Initial Scope Setup: 

• Configure the DUT to transmit the compliance pattern (CP9 – Pseudo-random data pattern). 

• Connect to the Transmitter port of the DUT using one of the probing configurations. If 

using pseudo-differential input (Ch1- Ch3), perform channel-channel deskew procedure 

and record the deskew value for Ch3.  

• Press the DEFAULT SETUP button. 

• Turn on Ch3 (if using pseudo-differential input) to view the signal under test.  

• Confirm that the pattern is being transmitted from the DUT. 
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Figure 7: Scrambled CP9 Pattern 

9.3 Recalling the Setup file  

i. Start DPOJET Application. Go to Analyze> USBSSP Essentials. 
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Figure 8 : Selecting DPOJET 

 

ii. From the test point, click setup and recall the setup from DPOJET USBSSP setup library. 
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Figure 9: Recalling Setup File 

iii. Select the appropriate setup file from the USB setups folder. Example: Select 

USBSSP_CP9_Normative.set to test for Compliance at TP1 of the specification.  

iv. Select ‘Recalc’ to run the measurements. 

9.4 Adjust the Vertical Amp and ensure proper De-skew calibration: 

This part of the procedure should be carried out the first time the Setup file is recalled on the 

oscilloscope to get accurate measurements.  

 

• Press the Zoom button to turn off zoom. 

• Turn off Math2 in the Math Menu.  

• Adjust Horizontal Scale to 20u sec/div.  

• Press the Run/Stop button so that the acquisition is running.  
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• Adjust the vertical amplitude of the active channels to be 9-10 divisions on the 

screen. This takes full advantage of the oscilloscopes A/D range without clipping the 

 waveform.  In this below example, Ch1 and Ch3 is set to 60 mV/div.  

• Go to the Deskew menu and enter the proper value for Ch3. 

• Adjust Horizontal Scale back to 10 us/div.  

• Turn on the Zoom and return the Zoom factor to 20000. The display should look similar 

to the following: 

 

Figure 10: Optimized Vertical Settings with 1Million UI Capture 
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9.5 SDLA settings 

• The utility recalls SDLA setup file and sequences through 7 presets using MATH1 as the input 

source. 

• USB3.1 specification requires evaluation up to seven combinations of CTLE + DFE and find 

optimum setting under which to make TX measurements 

9.5.1 SDLA CTLE equalizer  

 

Following are the EQ design values Adc and Fz values are variable, Pole and Zero settings for all gains, 

in SDLA: 

  

For Preset 6: 

• Fp1 and Fp2 values are fixed 

• Adc = 0.501187 

• Fz = .752 GHz 

• Fp1 = 1.5GHz 

• Fp2 = 5GHz 

9.5.2 SDLA clock recovery values 

 

• Bit Rate = 10Gb/s Nominal 

• PLL Type = 2 

• JTF BW MHz = 7.5 

• PLL Damp = 0.7 

• Clk Delay ps = 0 
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Fgiure-11: SDLA configuration 

9.5.3 Find Optimum CTLE + DFE Setting 

 

• Vary CTLE setting, run SDLA to auto adjust DFE.  Resultant waveform will appear in Ref4. 

• Use DPOJET to calculate eye height and eye width, record these values 

• Once measurements from all Presets are done, multiply eye height value  and eye width 

value, choose Preset with largest value 

• Perform TX measurements using this Preset. 
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9.5.4 Process waveform 

• Select the TpB button on the main SDLA window.   

• Select Math 1 as the input to SDLA 

• Select 10Gb/s as the data rate 

• Select Apply on the main SDLA window 

• SDLA will automatically apply the channel model ( not applicable in this case since there is 

no de-embedding)  

9.6 Run the Normative Setup file: 

• After SDLA is done processing, go to DPOJET Recall the normative setup from DPOJET 

• Hit "Clear" and "ReCalc" to run the measurements.  

• The results will be displayed as below. 

• After running the application, the results are as shown: 

 

Figure-14: DPOJET results for CP9 normative measurements 
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9.7 Run and Save Test Report:  

 

i. Select the Reports button in the DPOJET menu. 

ii. Press the ‘Save As’ button and enter the report name.  

9.7.1 The Report is as shown: 

 

 

Figure-15: Test Report Giving Pass/Fail Status 

9.8 Informative Test Point Example 

 

The following procedure discusses how to use DPOJET to test the Normative test point in the 

USB 3.1Specification. Differences in the procedure for testing the Informative test point are 

discussed but not in detail. The waveform is acquired at ‘TP1’ as with the Normative test. 
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9.9 Tx Eye Height MOI 

Definition:  

Eye Height measurement is defined as the clear vertical eye opening at the center of the unit interval. 

Height = High(min) – Low(max)  

 

Limits:  

Refer to Table 2 for the specified limits. 

 

Test Procedure:  

Ensure that Eye Height is selected in the Select menu.  

 

Measurement Algorithm:  

TX -EYE measurement.  

The Eye Height measurement is the measured minimum vertical eye opening at the zero reference level.  

The application calculates this measurement using the following equation:  

 

There are three types of eye height values:  

Eye Height: 

VEYE - HEIGHT  = VEYE - HI - MIN  - VEYE - LO - MAX 

Where: 

VEYE - HI - MIN  is the minimum of the high voltage at mid UI  

VEYE - LO - MAX  is the maximum of the low voltage at mid UI 

 

 Eye Height – Transition 

VEYE - HEIGHT -TRAN  = VEYE - HI -TRAN - MIN  - VEYE - LO -TRAN – MAX 

Where:  

 VEYE - HI -TRAN - MIN  is the maximum of the high transition bit eye voltage at mid UI  

VEYE - LO -TRAN - MAX  is the minimum of the high transition bit eye voltage at mid UI  

 

Eye Height – Non-Transition 

Where:  

V EYE - HEIGHT - NTRAN  = V EYE - HI - NTRAN - MIN  - V EYE - LO - NTRAN - MAX  
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Where: 

VEYE - HI - NTRAN - MIN  is the minimum of the high non-transition bit eye voltage at mid UI  

VEYE - LO - NTRAN – MAX is the maximum of the low non-transition bit eye voltage at mid UI 

 

9.10 TX Deterministic and Random Jitter (Dual Dirac) MOI  

 

Definition: 

 DJ–dd (Deterministic jitter only assuming the Dual Dirac Distribution) Deterministic Jitter is the 

statistics for all timing errors that follow deterministic behavior. Deterministic Jitter is typically 

characterized by its peak-to-peak value. Deterministic Jitter as defined above, but calculated based on a 

simplified assumption that the histogram of all deterministic jitter can modeled as a pair of equal- 

magnitude Dirac functions (impulses known as delta-functions).  

 

Limits:  

Refer to Table 2 for specified limits on the DJ–dd and RJ–dd measurements. 

 

Test Procedure:  

Ensure that Jitter DJ–dd is selected in the Select > Jitter menu.  

 

Measurement Algorithm:  

Dual Dirac Deterministic Jitter (DJ–dd) is the peak-to-peak magnitude for all timing errors exhibiting 

deterministic behavior, calculated based on a simplifying assumption that the histogram of all 

deterministic jitter can modeled as a pair of equal magnitude Dirac functions (impulses). A single DJ–dd 

value is determined for each acquisition, by means of RJ/DJ separation analysis. 

  

Rj/Dj Separation Based on Dual Dirac Model:  

Dual Dirac model based Rj/Dj separation method fits the Bathtub curve to a theoretical model of Rj and 

Dj where Rj is assumed to have a Gaussian distribution, Dj is assumed to have a distribution of two Dirac 

impulses with the same height. Curve fitting at different BER levels in Bathtub curve yields the standard 

deviation value of Rj and peak-to-peak value of Dj. The Bathtub curve is obtained from the spectrum 

analysis based or the arbitrary pattern analysis based Rj/Dj separation methods. Rj and Dj based on the  

Dual-Dirac model can be denoted as RJ. 

After RJg  and DJdd   are obtained, Tj can be calculated using 
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TJ ( BER)= 2Q( BER) × RJg +DJdd 

 where Q is the function of BER that has a value of about 7 when BER = 10- 12 . 

 

Eye opening is computed in the same way as it is computed in the spectrum analysis based Rj/Dj 

separation. Dual Dirac model based Rj/Dj separation method is used. Usually, actual Dj does not have a 

pure Dual Dirac distribution. So the value of RJ is often greater than the value of Rj obtained from the 

spectrum analysis based or the arbitrary pattern analysis based Rj/Dj separation. The value of DJ dd 

 is often less  than that of its corresponding one. 

9.11 TX Total Jitter MOI  

 

Definition:  

TJ@BER (Total Jitter at a specified Bit Error Rate (BER)). This combines the Random and Deterministic 

effects, and predicts a peak-to-peak jitter that will only be exceeded with a probability equal to the BER.  

 

Limits:  

Refer to Table 2 for specified limits on the TTX -EYE  measurement. 

 

Test Procedure:  

Ensure that Jitter TJ@BER is selected in the Select > Jitter menu. 

 

Measurement Algorithm:  

  Total Jitter at a specified Bit Error Rate (BER). This extrapolated value predicts a peak-to-peak jitter that 

will only be exceeded with a probability equal to the BER. It is generally not equal to the total jitter 

actually observed in any given acquisition. A single TJ@BER value is determined for each acquisition, 

by means of RJ/DJ separation analysis. 

 

9.12 TX Unit Interval Measurement MOI  

Test Definition Notes from the Specification:  

 

- UI (Unit Interval) is specified to be +/- 300 ppm  

- UI does not account for SSC dictated variations  
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Definition:  

UI is defined in the base specification.  

 

Limits:  

Refer to Table 2 for specified limits on UI measurement.  

 

Test Procedure:  

Ensure that the Unit Interval is selected in the Measurements > Standard > USB > Select > USB UI 

menu.  

 

Measurement Algorithm:  

This measurement is made over the analysis window of 250 consecutive bits (or over the entire record if 

the sw PLL is used) as defined in the base specification. The Unit Interval measurement calculates the 

cycle duration of the recovered clock. 

 

UI (n) = tR - CLK (n + 1) - t(n) 

UIAVG  = Mean(UI (n)) 

 R - CLK  is the recovered clock edge 

 n is the index to UI in the waveform 

 

9.13 TX De-Emphasized Differential Output Voltage (Ratio) MOI  

 

Definition: 

 VTX -DE - RATIO  (De-Emphasized Differential Output Voltage (Ratio)) is defined in the base specification. 

  

Test Definition Notes from the Specification: 

This is the ratio of the VTX - DIFFp - p of the second bit and following bits after a transition divided by the VTX 

- DIFFp – p of the first bit after a transition. 

  

Specified at the measurement point into a timing and voltage compliance test load as shown in the base 

specification over the specified number of UIs. Also refer to the transmitter compliance eye diagram 



Method of Implementation 

DPOJET USB3.1 MOI                                                                                                                                  

30 

 

shown in the base specification. 

 

Limits: 

 Refer to Table 2 for specified limits on the VTX -DE – RATIO measurement.  

 

 

Test Procedure:  

Ensure that De-Emphasis is selected in the Analyze > Jitter and Eye Analysis > Select > Ampl > 

T/nT Ratio menu.  

 

Measurement Algorithm: 

The de-emphasis measurement calculates the ratio of any non-transition eye voltage (2nd,3rd , 

etc. eyevoltage succeeding an edge) to its nearest preceding transition eye voltage (1st  eye 

voltage succeeding an edge), it is the ratio of the black voltages over the blue voltages. The 

results are given in dB.  

 

 

 

Figure 16: De-emphasis measurement 
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Where: 

v EYE - HI -TRAN is the high voltage at mid UI following a positive transition  

v EYE - LO -TRAN  is the low voltage at mid UI following a negative transition  

 vEYE - HI - NTRAN is the high voltage at mid UI following a positive transition bit 

  

v EYE - LO - NTRAN  is the low voltage at mid UI following a negative transition bit 

 

m is the index for all non-transition UIs  

 

n is the index for the nearest transition UI preceding the UI specified by m 

 

9.14 TX Differential Pk-Pk Output Voltage MOI  

 

Definition:  

V TX-DIFF—pp (Differential  Output  Pk-Pk  Voltage)  is  defined  in  the  base  specification  Rev  1.0.  This 

measurement is done using T-Tx-Diff-PP measurement available under Standards >> USBSSP tab. The  

Result panel would display the Mean , Maximum and Minimum differential output pk-pk voltage.  

 

Test Definition Notes from the Specification: 

VTX - DIFFp - p = 2* | VTX - D +  - VTX - D - |  

 

Specified at the measurement point into a timing and voltage compliance test load as shown in 

the base specification and measured over specified number of UIs. Also refer to the transmitter 

compliance eye diagram shown in the base specification. 
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Limits: 

Refer to Table 2 for specified limits on the VTX - DIFFp – p measurement. 

 

Test Procedure: 

 Ensure that VTX - DIFFp – p is selected in the Jitter and Eye Analysis (DPOJET) > USBSSP > 

Select menu. This measurement is available under Standards > USBSSP tab. 

 

Measurement Algorithm:  

Differential Peak Voltage Measurement: The Differential Peak Voltage measurement returns two 

times the larger of the Min or Max statistic of the differential voltage waveform.  

VDIFF - PK  = 2 * Max( Max(v DIFF (i)); Min(v DIFF (i))). 

 

Where: 

 i is the index of all waveform values 

vDIFF  is the differential voltage signal 

9.15 TX Minimum Pulse Width MOI  

 

Definition:  

TMIN-PULSE-TJ   (Instantaneous lone pulse width including all Jitter source measurement) is defined 

in the specification Rev1.0.  

This measurement is done using the USB3.1 Tmin-Pulse-Tj measurement available under 

Standards > USBSSP tab. The Result panel would display the minimum pulse width results.  

 

Test Definition Notes from the Specification:  

TMIN-PULSE-TJ   (Instantaneous lone pulse width including all Jitter source) is measured from 

transition center to the next transition center, and that the transition centers will not always occur 

at the differential zero crossing point. In particular, transitions from a de-emphasized level to a 

full level will have a center point offset from the differential zero crossing. 

 

Limits:  

Refer to Table 2 for specified limits on the T min-Pulse-Tj measurement.  
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Test Procedure:  

Ensure that TMIN-PULSE-TJ  is selected in the Jitter and Eye Analysis (DPOJET) > USBSSP> 

Select menu. This measurement is available under Standards >  USBSSP tab. 

 

Measurement Algorithm: 

Tmin-Pulse-Tj (minimum single pulse width TMin-Pulse including all Jitter source) is measured from  

one transition center to the next.  The application calculates TMin-Pulse-Tj using the following equation:  

Tmin-Pulse-Tj = (Tn+1 – Tn) 

 

Where: 

 Tmin-Pulse-Tj is the minimum pulse width  

 T is the transition center 

 

9.16 TX Minimum Pulse Width (Deterministic Jitter source) MOI  

 

Definition:  

T MIN-PULSE-DJ (Instantaneous lone pulse width including only deterministic jitter source 

measurement) is defined in the specification Rev1.0.  

 

This measurement is done using the USB3.1 Tmin-Pulse-Dj measurement available under 

Standards >> USBSSP tab. The Result panel would display the minimum pulse width results.  

 

Test Definition Notes from the Specification:  

T MIN-PULSE-DJ  (Instantaneous lone pulse width including only deterministic jitter source) is 

measured from transition center to the next transition center, and removing all random jitter 

source from the total jitter.  

 

Limits:  

Refer to Table 2 for specified limits on the T MIN-PULSE-DJ  measurement. 
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Test Procedure:  

Ensure that TMIN-PULSE-TJ  is selected in the Jitter and Eye Analysis (DPOJET) > USBSSP> 

Select menu. This measurement is available under Standards > USBSSP tab. 

 

Measurement Algorithm: 

 Tmin-Pulse-Dj (minimum single pulse width TMin-Pulse including only deterministic 

jitter) is measured from one transition center to the next. 

 

The application calculates Tmin-Pulse-Dj using the following steps:  

 

• Find the TIE trend for the given waveform 

• Take the FFT of the TIE trend.  

• Separate the Rj and Dj values from the TIE spectrum 

• Remove the Rj components from the TIE spectrum (Find the noise floor and  

• replace the Rj values with the noise values) 

• Take IFFT of the TIE spectrum without Rj component and reconstruct the clock  

• Based on the TIE trend without Rj components. 

• Find the minimum pulse width in this reconstructed clock. 

 

9.17 TX SSC Modulation Rate MOI 

  

Definition:  

Spread spectrum modulation, which can be defined as any modulation technique that requires a 

transmission bandwidth much greater than the modulating signal bandwidth, independently of 

the bandwidth of the modulating signal.  

 

Test Definition Notes from the Specification:  

• All ports are required to have Spread Spectrum  Clocking(SSC) modulation.  

• The SSC Modulation may not violate phase slew rate specification. 
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Figure 17: SSC Modulation profile 

 

Limits: 

 Refer to Table 2 for specified limits on tSSC-MOD-RATE measurement. 

 

Test Procedure: 

Ensure that TSSC-MOD-RATE measurement is selected in the Jitter and Eye Analysis (DPOJET) 

>USBSSP Essentials > Select menu.  

 

Select the Jitter and Eye Analysis (DPOJET) > Configure from the panel and set the  

 Configure > Constant Clock > Mean and, Configure > Filter > Low pass > 2nd default) as 

shown in figure below. Order > Frequency > 1.98 MHz (Which is elected by default) as shown 

in figure below. 

 

 

 

Figure 18: Filter for SSC Mod Rate measurement 
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Measurement Algorithm:  

 

• Run the measurement and get the SSC profile 

• Find the 50% edges on the SSC profile.  

• Find time difference between the  consecutive crossings of the mid reference voltage level ( 

∆t = Tn+1 - Tn ; where Tn - is the VRefMid crossing time, T n+1 – is next VRefMid crossing 

time) 

• Calculate the Modulation Rate as 1/∆t ( Modulation Rate = 1/∆t )  

 

9.18 TX SSC Frequency Deviation Max MOI  

 

Definition:  

SSC Frequency Deviation Max, can be defined as the maximum frequency shift as a function of 

time.  

 

Test Definition Notes from the Specification:  

-- The data rate is modulated from 0 to -5000 ppm for nominal data rate frequency and scales 

with data rate.  

-- This is measured below 2MHz only.  

 

Limits:  

Refer to Table 2 for specified limits on t SSC-FREQ-DEV-MAX measurement 

 

Test Procedure:  

Ensure that TSSC-MOD-RATE measurement is selected in the Jitter and Eye Analysis (DPOJET) 

>USBSSP Essentials > Select menu.  

Select the Jitter and Eye Analysis (DPOJET) > Configure from the panel and set the  

 Configure > Constant Clock > Mean and, Configure > Filter > Low pass > 2nd default) as 

shown in figure below. Order > Frequency > 1.98 MHz (Which is elected by default) as shown 

in figure below. 
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Figure 19: Filter for SSC Frequency Deviation Min measurement 

 

Measurement Algorithm:  

• Find the 50% edges on the SSC profile 

• Between the 'n' and 'n+1' th edge find the Low value. 

• Find the Minimum Frequency deviation as Low. 

• Freq Dev Min (ppm) = {(Minimum Frequency - nominal Data rate)/ nominal Data rate} * 

1e6.  Represent the FreqDev in terms of ppm (parts per million) 

 

9.19 SSC df/dt measurement 

 

Definition: 

This is one of the normative SSC measurements by the USB3.1 specification. This is measured 

over a 0.5µs interval using CP10 compliance pattern. 

 

Limits:  

Refer to Table 2 for specified limits on SSC df/dt  measurement, which is max 1250 ppm/us 

 
Measurement algorithm: 

The measurements are low pass filtered using a filter with 3 dB cutoff frequency that is 60 times 

the modulation rate. The 60 times 33 KHz accounts to 1.98MHz. 

 

The filter stop-band rejection is greater or equal to a second order low-pass of 20 dB per decade. 

The evaluation of the maximum df/dt is achieved by inspection of the low-pass filtered 

waveform.  
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9.20 Preshoot measurement 

Definition: 

This is one of the normative equalization measurements by the USB3.1 specification. This test 

verifies that the transmitter meets requirements for transmit equalization.  

Preshoot measurement is measured by comparing the 64-zeroes/64- ones PP voltage with 

preshoot and de-emphasis(V1 or CP15) against without preshoot and with de-emphasis(V3 or 

CP14). This voltages should be calculated on the low frequency region of the measurement 

where 64 0’s and 64 1’s are together. So Preshoot is V3/V1 calculated in dB. 

Limits:  

Refer to Table 2 for specified limits on Preshoot  measurement. 

 
Measurement algorithm: 

Confirm that the transmitter equalization falls within the limits of the specification 

a. Set preset 0 

b. Configure DUT transmitter to output alternating square pattern of 64 0’s and 64 

1’s on all lanes with SSC turned on with preshoot and with de-emphasis  

c. Average one cycle using 150 cycles; no CDR and no interpolation to be used 

 

d. Measure differential amplitude voltage of bits 57-62 

(|�������	
��
�64	����	��	1
��
 − �������	
��
�64	����	��	0

��
|
 and mark it as V1. 

e. Configure DUT transmitter to output alternating square pattern of 64 0’s and 64 

1’s on all lanes with SSC turned on without preshoot but with de-emphasis  
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f. Average one cycle using 150 cycles; no CDR and no interpolation to be used 

 
g. Measure differential amplitude voltage of bits 57-62 

(|�������	
��
�64	����	��	1
��
 − �������	
��
�64	����	��	0

��
|
 and mark it as V3. 

Set Preshoot to be
��

��
�  

Test procedure: 

a. Ensure that USBSSP Preshoot  measurement is selected in the Jitter and Eye 

Analysis (DPOJET) >USB SSP Essentials > Select menu.  

b. From Horiz/Acq menu, select Horizontal setup and set Sample Rate to 100GS/s 

and Record Length to 20M. 

c. Capture CP14 and CP15 from the DUT in oscilloscope with the above 

configuration. 

d. Load Preshoot_CP14byCP15.set file from 

‘C:\Users\Public\Tektronix\TekApplications\USBSSP\Setups\DPOJET Setups’ 

location.  

e. Load previously saved CP14 waveform in Ref1 and CP15 waveform in Ref2 

f. Run the measurement. DPOJET will show Preshoot measurement result with limit 

applied. 

GPIB Command:  

DPOJET:ADDMEAS USBSSPPRESHOOT 
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9.21 DeEmphasis measurement 

Definition: 

This is one of the normative equalization measurements by the USB3.1 specification. This test 

verifies that the transmitter meets requirements for transmit equalization.  

De-emphasis measurement is measured by comparing the 64-zeroes/64- ones PP voltage 

with preshoot and de-emphasis(V1 or CP15) against with no de-emphasis and with preshoot(V2 

or CP13). This voltages should be calculated on the low frequency region of the measurement 

where 64 0’s and 64 1’s are together. So Preshoot is V3/V1 calculated in dB. 

Limits:  

Refer to Table 2 for specified limits on DeEmphasis  measurement. 

 
Measurement algorithm: 

Confirm that the transmitter equalization falls within the limits of the specification 

a. Set preset 0 

b. Configure DUT transmitter to output alternating square pattern of 64 0’s and 64 

1’s on all lanes with SSC turned on with preshoot and with de-emphasis  

c. Average one cycle using 150 cycles; no CDR and no interpolation to be used 

 

d. Measure differential amplitude voltage of bits 57-62 

(|�������	
��
�64	����	��	1
��
 − �������	
��
�64	����	��	0

��
|
 and mark it as V1. 

 

e. Configure DUT transmitter to output alternating square pattern of 64 0’s and 64 

1’s on all lanes with SSC turned on with preshoot and with no de-emphasis  

f. Average one cycle using 150 cycles; no CDR and no interpolation to be used. 
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g. Measure differential amplitude voltage of bits 57-62 

(|�������	
��
�64	����	��	1
��
 − �������	
��
�64	����	��	0

��
|
 and mark it as V2. 

Set De-emphasis to be
��
��
�  

Test procedure: 

a. Ensure that USBSSP Preshoot  measurement is selected in the Jitter and Eye 

Analysis (DPOJET) >USB SSP Essentials > Select menu.  

b. From Horiz/Acq menu, select Horizontal setup and set Sample Rate to 100GS/s 

and Record Length to 20M. 

c. Capture CP13 and CP15 from the DUT in oscilloscope with the above 

configuration. 

d. Load DeEmphasis_CP15ByCP13.set file from 

‘C:\Users\Public\Tektronix\TekApplications\USBSSP\Setups\DPOJET Setups’ 

location.  

e. Load previously saved CP15 waveform in Ref1 and CP13 waveform in Ref2 

f. Run the measurement. DPOJET will show DeEmphasis measurement result with 

limits applied. 

GPIB Command:  

DPOJET:ADDMEAS USBSSPDEEMPHASIS 
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9.22 LFPS Measurements 

Definition: 

Low Frequency Periodic Signaling (LFPS) is used for side band communication between 

two ports across a link that is in a low power link state. There are few parameters which 

have to measure to perform complete LFPS measurements.  

Those parameters are: tPeriod (LFPS TPeriod), tRiseFall2080 (LFPS Rise Time/LFPS Fall 

Time), Duty cycle, VCM-AC-LFPS, and VTX-DIFF-PP-LFPS. 
 

Limits:  

Refer to Table 2 for specified limits on LFPS measurements. 

 

Scope Settings: 

• Enable Ch1 and Ch3 and set the vertical scale to 100mV/Div. 

• Set the Record Length to 5M and Sample rate to 50GS/s. 

• Trigger on Ch1 and set the Trigger type to width with level 140 mV, upper limit 50ns and 

lower limit 10 ns. Put the acquisition mode into ‘Single’. 

 

Math Settings: 

• Go to Math Setup and set Math1-Math3 with the following: 

• Math1=CH1-CH2. 

• Math3=(CH1+CH2)/2  

To measure all LFPS parameters, select the following measurements from Jitter and Eye 

Analysis >> Select menu. 

 

 

LFPS Parameter 

 

DPOJET Parameter 

 

Source 
 

tBurst 

 

LFPS TBurst 

 

Math1 
 

tPeriod 

 

LFPS TPeriod 

 

Math1 
 

  tRepeat 

 

LFPS TRepeat 

 

Math1 
 

tRiseFall2080 

 

LFPS Fall Time 

 

Math1 
 

tRiseFall2080 

 

LFPS Rise Time 

 

Math1 
 

Duty Cycle 

 

LFPS Duty Cycle 

 

Math1 
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VCM-AC-LFPS 

 

LFPS VTX-DIFF-PP 

 

Math1 
 

VTX-DIFF-PP-LFPS 

 

 LFPS Vcm-AC CM 

 

Math1,Math3 

LBPS tPeriod LBPS t Period Math1 

LBPS tWPM  Math1 

SCD tRepeat  Math1 

 

Select the measurements listed above. Open Source Configuration and set reference levels to 

absolute. Set mid reference level to 150mV and hysteresis to 50 mV for Math1 (Differential 

signal). 

 

Figure 21: Math1 Source configuration 
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Figure 22: LFPS measurements 

 

9.22.1 LFPS signal details: 
 

 

 
 

Figure 23: LFPS signaling 

 

• For  LFPS tPeriod,  LFPS Rise Time, Duty  cycle,  VCM-AC-LFPS,  and  VTX-DIFF-PP-

LFPS measurements the start of an LFPS burst is defined as starting when the absolute 
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value of the differential voltage has exceeded 100 mV and the end of an LFPS burst is 

defined as when the absolute value of the differential voltage has been below 100 mV for 50 

ns. 

• LFPS parameters are only measured during the period from 100 nanoseconds after the 

burst start to 100 nanoseconds before the burst stop. 

• For  VCM-AC-LFPS high pass filter with frequency 30KHz is applied to common mode 

signal(Math3) before doing the measurement. 

 

 

Figure 24: LBPS  measurements 

 

9.22.2 Trigger settings: 

Uses both A and B trigger.  It’s a width trigger – level 140mV.. upper 40ns ..lower 10ns (both A and B 

trigger used) 
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Figure 25: LBPS signaling 

9.23 LBPM 

9.23.1 LBPS signal details: 
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Figure 26: LBPS signaling 

LBPS is based on PWM with embedded transmit clock and is basically constructed with two distinctive 

electrical states, which are LFPS signaling state and EI state.  Two logic states are defined based on 

LBPS.   

• Logic ‘0’ is defined within the unit interval of tPWM as one-third of LFPS signal followed 

by two-third of EI.  

• Logic ‘1’ is defined within the unit interval of tPWM as two-third of LFPS signal followed 

by one-third of EI. 

 

 

 

9.23.2 Trigger settings: 

Width trigger level -140mv with upper limit 2.6us and lower limit 1.8us 
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Figure 27: LBPS trigger settings 

9.23.3 LBPM Results: 

 

 

Figure 28: LBPM Results 
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9.24 SCD measurement 

SuperSpeedPlus Capability Declaration (SCD) is a step for a SuperSpeedPlus port, while in the 

Polling.LFPS substate, to identify itself as SuperSpeedPlus capable by transmitting Polling.LFPS signals 

with specific patterns unique to SuperSpeedPlus ports.  This section defines SuperSpeedPlus specific 

patterns in SCD1 and SCD2.  The use of SCD1 and SCD2 is described in Chapter 7. 

9.24.1 SCD signal details: 

 

SCD1 is defined as “0010” and SCD2 is defined as “1101”.  The transmission of SCD1/SCD2 shall be 

based on the following. 

• The transmission shall be LSB first.  

• The transmission shall be completed with tBurst followed by extended electrical idle (EI) 

of at least 2x tRepeat. 
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Figure 29: SCD signaling 

 

Figure 30: SCD measurement and configuration 

9.24.2 Trigger settings 

Uses only A trigger. The width trigger with horizontal delay is set to 140 us. 
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Figure 31: SCD trigger settings 
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9.24.3 SCD Results 

 

 

Figure 32: SCD Results 

Important Note:  

If you are not able to acquire only SCD signals, then we recommend to scope cursors.  

Steps: 

• Turn on the scope cursors. 

• Place the cursor 1 and 2 at the start of the signal and cursor 2 at the end of the signal including 

electrical idle. 

• GO to DPOJET 

o Select configuration for the selected measurement 

o Go to Global tab, turn on cursors. 

o Run the measurement, this will help you to isolate other patterns of interest. 

This note is applicable to LFPS, LBPM and SCD signals. 
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Figure 33: DPOJET Cursor turn ON 

 

 


